[rspec-devel] [ rspec-Bugs-11296 ] svn export gives errors

noreply at rubyforge.org noreply at rubyforge.org
Fri Jun 1 20:26:59 EDT 2007


Bugs item #11296, was opened at 2007-06-01 15:47
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=3149&aid=11296&group_id=797

Category: rails plugin
Group: None
Status: Open
Resolution: None
Priority: 3
Submitted By: Jim Morris (wolfmanjm)
Assigned to: Nobody (None)
Summary: svn export gives errors

Initial Comment:
Trying to import via piston (svn export) there is an inconsistent line ending error...

> piston import svn://rubyforge.org/var/svn/rspec/tags/CURRENT/rspec_on_rails vendor/plugins/rspec_on_rails
svn: File 'vendor/plugins/rspec_on_rails/lib/spec/rails/version.rb' has inconsistent newlines
svn: Inconsistent line ending style
/usr/lib/ruby/gems/1.8/gems/piston-1.3.3/lib/piston/command.rb:43:in `svn': Command svn add --force --quiet vendor/plugins/rspec_on_rails resulted in an error: (RuntimeError)

        from /usr/lib/ruby/gems/1.8/gems/piston-1.3.3/lib/piston/commands/import.rb:50:in `run'
        from /usr/lib/ruby/gems/1.8/gems/piston-1.3.3/lib/transat/parser.rb:131:in `execute'
        from /usr/lib/ruby/gems/1.8/gems/piston-1.3.3/lib/transat/parser.rb:127:in `each'
        from /usr/lib/ruby/gems/1.8/gems/piston-1.3.3/lib/transat/parser.rb:127:in `execute'
        from /usr/lib/ruby/gems/1.8/gems/piston-1.3.3/lib/transat/parser.rb:104:in `parse_and_execute'
        from /usr/lib/ruby/gems/1.8/gems/piston-1.3.3/bin/piston:10
        from /usr/bin/piston:16:in `load'
        from /usr/bin/piston:16


----------------------------------------------------------------------

>Comment By: Jim Morris (wolfmanjm)
Date: 2007-06-01 17:26

Message:
I'm using svn, version 1.4.3 (r23084)
on Ubuntu Linux Feisty.
piston (1.3.3)

It actually checked out ok, but the failure was on the svn add

The file
vendor/plugins/rspec_on_rails/lib/spec/rails/version.rb had
DOS style line endings, but was inconsistent, so some \n and
some \r\n When I did a dos2unix on the file it worked fine.


----------------------------------------------------------------------

Comment By: David Chelimsky (dchelimsky)
Date: 2007-06-01 16:28

Message:
I'm not experiencing this. I'm using Mac OS 10.4.9, piston 1.3.3 and svn 1.4.3. You?

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=3149&aid=11296&group_id=797


More information about the rspec-devel mailing list