[rspec-devel] need help getting a word right

Ian Dees undees at gmail.com
Thu Jul 19 03:55:24 EDT 2007


Hi, all.

Quoth Dave:

>   it do
>     @thing.should be_something
>   end
> end
...
> But "it do" is driving me mad :(

You and me both:
http://rubyforge.org/pipermail/rspec-devel/2007-April/002415.html

> We need a better word. Of course, 'specify' has not been completely
> removed, so you can still do this:

I know you're not totally sold on using "specify" here, but I think it
looks okay.

If you really want to move away from "specify," then would there be a
way to keep "it" but add a do-nothing "return self" method to the
example object?  Something like "must?"

it.must do
  @thing.should be_something
end

--Ian


More information about the rspec-devel mailing list