[rspec-devel] [ rspec-Patches-12010 ] Nicer failure message formatting

noreply at rubyforge.org noreply at rubyforge.org
Tue Jul 10 11:34:18 EDT 2007


Patches item #12010, was opened at 2007-07-05 04:32
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=3151&aid=12010&group_id=797

Category: expectation module
Group: None
>Status: Closed
>Resolution: Accepted
Priority: 3
Submitted By: Wincent Colaiuta (wincent)
>Assigned to: Aslak Hellesøy (aslak_hellesoy)
Summary: Nicer failure message formatting

Initial Comment:
Patch that implements more readable failure formatting as discussed in this thread:

http://rubyforge.org/pipermail/rspec-users/2007-June/002153.html

----------------------------------------------------------------------

>Comment By: Aslak Hellesøy (aslak_hellesoy)
Date: 2007-07-10 11:34

Message:
Great patch! Applied in r2164.

----------------------------------------------------------------------

Comment By: Wincent Colaiuta (wincent)
Date: 2007-07-05 06:02

Message:
Will attach alternative patch as commented previously.

----------------------------------------------------------------------

Comment By: Wincent Colaiuta (wincent)
Date: 2007-07-05 05:59

Message:
Darn transparent proxy... looks like I got logged out again;
it let me attach the patch but silently discarded the
comment I'd included... Here it is again:

Ok, so I've revised the patch to implement what you suggest.

I will also attach a second patch same as the first one but
which includes one other change: treating "=~" like "==" and
"===". For me the three operators "go" together
conceptually, so to me this:

expected: /blah/,
     got: "other" (using ~=)

Reads better than this:

expected: =~ /blah/,
     got:    "other"

Or the way it looked in my first shot at this patch:

expected: =~ /blah/,
got     : "other"

Or prior to the patch:

expected: =~ /blah/, got "other"

So anyway, like I said, will attach that one as a separate
patch because I realize it might be more contentious.

----------------------------------------------------------------------

Comment By: David Chelimsky (dchelimsky)
Date: 2007-07-05 04:48

Message:
ps - make sure you view that last comment in a fixed width font :)

----------------------------------------------------------------------

Comment By: David Chelimsky (dchelimsky)
Date: 2007-07-05 04:47

Message:
On http://pastie.textmate.org/76180 you describe this:

expected: blah
     got: other

But I'm seeing this:

expected: blah
got     : other

Of the two, I prefer the former.

Also, this is all good for equality, but not as good for comparisons:

expected: > 6
     got: 5

I'd rather see:

expected: > 6
     got:   5

I won't have time to get this right immediately, but if you want to take another crack at a patch based on these suggestions, I'd be happy to apply it.

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=3151&aid=12010&group_id=797


More information about the rspec-devel mailing list