[rspec-devel] [ rspec-Bugs-8218 ] heckle_runner.rb doesn't work with heckle >= 1.2.0

noreply at rubyforge.org noreply at rubyforge.org
Sat Jan 27 13:45:29 EST 2007


Bugs item #8218, was opened at 2007-01-27 18:45
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=3149&aid=8218&group_id=797

Category: runner module
Group: None
Status: Open
Resolution: None
Priority: 3
Submitted By: Michal Kwiatkowski (infrared)
Assigned to: Nobody (None)
Summary: heckle_runner.rb doesn't work with heckle >= 1.2.0

Initial Comment:
Heckle::Base class dissapeared in heckle 1.2, so definition of Heckler in heckle_runner.rb is invalid and yields an error. In 1.2 there is no Heckle module, just a global Heckle class.

I've attached a patch (against current trunk) that fixes this issue.

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=3149&aid=8218&group_id=797


More information about the rspec-devel mailing list