[rspec-devel] [ rspec-Bugs-7781 ] rspec will not install on RubyGems 0.9.1

noreply at rubyforge.org noreply at rubyforge.org
Fri Jan 12 14:12:03 EST 2007


Bugs item #7781, was opened at 2007-01-12 11:12
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=3149&aid=7781&group_id=797

Category: None
Group: None
Status: Open
Resolution: None
Priority: 3
Submitted By: Eric Hodel (drbrain)
Assigned to: Nobody (None)
Summary: rspec will not install on RubyGems 0.9.1

Initial Comment:
Due to a security flaw in RubyGems, 0.9.1 and newer will no longer allow rspec to be installed:

$ gem --version # actually, the downloaded 0.9.0.10 doesn't have the patch, use SVN
0.9.0.10
$ sudo gem install rspec --version 0.7.5
ERROR:  While executing gem ... (Gem::InstallError)
    attempt to install file into "../web_spec/web_test_html_formatter.rb"


----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=3149&aid=7781&group_id=797


More information about the rspec-devel mailing list