[rspec-devel] [ rspec-Bugs-6095 ] Arbitrary operators do not all work, as per tutorial

noreply at rubyforge.org noreply at rubyforge.org
Wed Oct 11 14:09:27 EDT 2006


Bugs item #6095, was opened at 2006-10-11 00:30
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=3149&aid=6095&group_id=797

Category: None
Group: None
Status: Closed
Resolution: None
Priority: 3
Submitted By: Nobody (None)
Assigned to: Nobody (None)
Summary: Arbitrary operators do not all work, as per tutorial

Initial Comment:
In version 0.6.3, writing a specification such as,

@setup_variable.attribute.should_be > 0

where attribute returns a comparable object (in the case I was testing, a Fixnum), fails with a message complaining about method >? missing from the returned object.

I have yet to test this on 0.6.4, yet, so I am unsure whether it has been fixed between the two versions.

----------------------------------------------------------------------

Comment By: Joshua Bowers (joshuabowers)
Date: 2006-10-11 11:09

Message:
Ah. Thank you for the update! I'll get around to updating, then.

----------------------------------------------------------------------

Comment By: David Chelimsky (dchelimsky)
Date: 2006-10-11 08:39

Message:
This feature was added to rspec 0.6.4, so it is not expected to work with 0.6.3.

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=3149&aid=6095&group_id=797


More information about the rspec-devel mailing list