[rspec-devel] underscores, sugar, and more and more bugs
wilsonb at gmail.com
Mon Nov 20 17:29:30 EST 2006
On 11/20/06, David Chelimsky <dchelimsky at gmail.com> wrote:
> On 11/20/06, Nick Sieger <nicksieger at gmail.com> wrote:
> > On 11/20/06, David Chelimsky <dchelimsky at gmail.com> wrote:
> > >
> > > Again, does anyone see a big difference between:
> > >
> > > @thing.should_be.something
> > > @thing.should_be :something
> > >
> > > For me, the latter cleanly separates what is framework (should_be)
> > > from what is supposed to be in your code (:something)
> > Now that you put it that way...no.
> > > Either allows us to eliminate method_missing, so this is purely a
> > > syntax question.
> > Yep, and I don't wish to make a bikeshed out of this issue, but what do you
> > think about supporting both?
> In my experience, supporting 2 ways to do the same thing makes it
> confusing to understand how to use, binds implementation to more API,
> leads to more hackage under the hood. I feel bad about it.
I think that the current issue with underscores shows that picking one
way is often the best answer. :)
More information about the rspec-devel