[rspec-devel] underscores, sugar, and more and more bugs
dchelimsky at gmail.com
Mon Nov 20 16:59:16 EST 2006
On 11/20/06, Nick Sieger <nicksieger at gmail.com> wrote:
> On 11/20/06, David Chelimsky <dchelimsky at gmail.com> wrote:
> > Again, does anyone see a big difference between:
> > @thing.should_be.something
> > @thing.should_be :something
> > For me, the latter cleanly separates what is framework (should_be)
> > from what is supposed to be in your code (:something)
> Now that you put it that way...no.
> > Either allows us to eliminate method_missing, so this is purely a
> > syntax question.
> Yep, and I don't wish to make a bikeshed out of this issue, but what do you
> think about supporting both?
In my experience, supporting 2 ways to do the same thing makes it
confusing to understand how to use, binds implementation to more API,
leads to more hackage under the hood. I feel bad about it.
> rspec-devel mailing list
> rspec-devel at rubyforge.org
More information about the rspec-devel