[rspec-devel] Running specs with TextMate bundle

Luke Redpath luke at agileevolved.com
Fri Nov 3 09:20:42 EST 2006


Hi Brandon

I was having this problem - it seems to be related to the recent  
updates to TextMate - you'll probably find that your TM_SUPPORT_PATH  
variable (Preferences > Advanced) has disappeared. You need to re-add  
this. See here:

http://macromates.com/textmate/manual/shell_commands#search_path

Cheers
Luke

On 3 Nov 2006, at 13:06, Brandon Keepers wrote:

> Luke,
>
> Since the last few updates, I haven't been able to run the specs in
> textmate.  It worked the day that you announced it to the list, but
> then I updated the next day an it hasn't worked since.  I just
> updated a few minutes ago and I am still getting the same error:
>
> /tmp/temp_textmate.USgxnG:34: command not found: spec
> invitation_spec.rb /tmp/temp_textmate.USgxnG:7:in `passed?':
> undefined method `match' for nil:NilClass (NoMethodError) from /tmp/
> temp_textmate.USgxnG:23
>
> Any ideas?
>
> Thanks,
> Brandon
> _______________________________________________
> rspec-devel mailing list
> rspec-devel at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-devel

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/rspec-devel/attachments/20061103/4874bc2a/attachment-0001.html 


More information about the rspec-devel mailing list