[rspec-devel] script/generate rspec issue on trunk (rev 1021)

aslak hellesoy aslak.hellesoy at gmail.com
Fri Nov 3 05:46:32 EST 2006


On 11/3/06, George Anderson <george at benevolentcode.com> wrote:
> I just updated to rev. 1021, built and installed the gem, and updated the
> plugin to rev. 1021.  When I  ran "script/generate rspec"  I got:
>
> Missing RspecGenerator class in
> script/../config/../vendor/plugins/rspec/generators/rspec/rspec_generator.rb
>
> Then in rspec_generator.rb, I changed:
>
>     class RSpecGenerator < Rails::Generator::Base
>
> to
>
>     class RspecGenerator < Rails::Generator::Base
>
> (note the differing capitalization of "spec")
>
> After that, "script/generate rspec" ran as expected.
>

Thanks. Fixed on trunk. It was a recent regression caused by cleaning
up the spelling of RSpec and a little too much got cleaned up.

>
> Protocol question:  Is this (rspec-devel at rubyforge.org) the right forum for
> raising this issue?  Or rspec-users at rubyforge.org?  Or add it directly to
> the tracker?  My guess is to vet the issue on this (devel) list in case the
> problem is on my end.
>

For small things like this (that can be fixed in less than 5 minutes)
either mailing list is fine.
For bigger things, please use the tracker and ask first here if you're in doubt.

Cheers,
Aslak

> Thanks,
>
> George
>
> _______________________________________________
> rspec-devel mailing list
> rspec-devel at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-devel
>
>


More information about the rspec-devel mailing list