[Rspec-devel] Rake Task - not for Windows ?

DeeJay smartgpx at gmail.com
Tue Aug 22 03:46:29 EDT 2006

"Question to DeeJay:
1) What exactly should we do to reproduce this on a windows box?
2) Does the spec task behave badly for both plain ruby and rcov usage?"

To answer your questions first -

1)  As documented in #4891

>  rake examples_with_rcov --trace

where rakefile contains  the example given
in the first reversed-out code box at

(rcov is installed on the system and produces results in coverage if invoked
from the command line.)

The response, ignoring the file-selection report, is:

rake aborted!
undefined method `exitstatus' for nil:NilClass
[..further backtrace suppressed]

2) This only happens when t.rcov = true is set

Some background.

Assume (as a 'user-story' if you like) that I am coming to this with little
experience or understanding of rake, rcov or rspec.

Refer to http://rspec.rubyforge.org/tools/rcov.html

What is the nature of the code in the reversed-out box? It looked like Ruby,
I tried passing it to ruby. Silence. It starts with "require 'rake' ", so it
seem logical to try to pass it to rake, but I tried. Silence. So I started
clicking through
and when I got to the source for 'run' and could not find 'sh' documented in
fxri I assumed I had found the  reason for what I perceived to be an
incompatibility between SpecTask and Windows.

A note with the sample task documenting how to run it would make
life easier for newcomers.  :-)}

I now know, by reference to bug #4891, that I have to invoke rake
with an argument that is extracted from a text string buried half-way
down the sample code. (I think I can see why, but I hope you can
see why it isn't obvious to a newcomer?)

Thanks for listening -

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/rspec-devel/attachments/20060822/3a7c9e5d/attachment.html 

More information about the Rspec-devel mailing list