[Rspec-devel] RSpec on Rails fubarred on edge rails?

Luke Redpath luke at agileevolved.com
Thu Aug 10 18:04:21 EDT 2006


I'm definitely not using them.

Its probably a simple fix so would you like me to submit a patch to  
save some time?

Cheers
Luke

On 10 Aug 2006, at 22:26, aslak hellesoy wrote:

> It doesn't look like it's fucked up beyond all recognition - this is
> just warnings ;-)
>
> In any case - I haven't seen it (yet). I'm not near the rspec code
> right now, but have you checked whether your own code uses the
> deprecated variables - or if the rspec rails code does?
>
> Aslak
>
> On 8/10/06, Luke Redpath <luke at agileevolved.com> wrote:
>>
>> Is anybody else having problems running controller specs with edge  
>> rails?
>> This is possibly an issue in 1.1.6 but I haven't been able to  
>> confirm that.
>>
>> It relates to the deprecation of @params, @session which now throws
>> deprecation warnings.
>>
>> Here's some example output:
>>
>> @session is deprecated! Call session.inspect instead of  
>> @session.inspect.
>> Args: [] (inspect_for_expectation_not_met_error at
>> /usr/local/lib/ruby/gems/1.8/gems/rspec-0.5.16/lib/spec/api/helper/ 
>> should_base.rb:10)
>> @flash is deprecated! Call flash.inspect instead of  
>> @flash.inspect. Args: []
>> (inspect_for_expectation_not_met_error at
>> /usr/local/lib/ruby/gems/1.8/gems/rspec-0.5.16/lib/spec/api/helper/ 
>> should_base.rb:10)
>> @params is deprecated! Call params.inspect instead of  
>> @params.inspect. Args:
>> [] (inspect_for_expectation_not_met_error at
>> /usr/local/lib/ruby/gems/1.8/gems/rspec-0.5.16/lib/spec/api/helper/ 
>> should_base.rb:10)
>> @session is deprecated! Call session.inspect instead of  
>> @session.inspect.
>> Args: [] (inspect_for_expectation_not_met_error at
>> /usr/local/lib/ruby/gems/1.8/gems/rspec-0.5.16/lib/spec/api/helper/ 
>> should_base.rb:10)
>> @params is deprecated! Call params.inspect instead of  
>> @params.inspect. Args:
>> [] (inspect_for_expectation_not_met_error at
>> /usr/local/lib/ruby/gems/1.8/gems/rspec-0.5.16/lib/spec/api/helper/ 
>> should_base.rb:10)
>> @flash is deprecated! Call flash.inspect instead of  
>> @flash.inspect. Args: []
>> (inspect_for_expectation_not_met_error at
>> /usr/local/lib/ruby/gems/1.8/gems/rspec-0.5.16/lib/spec/api/helper/ 
>> should_base.rb:10)
>> F at session is deprecated! Call session.inspect instead of  
>> @session.inspect.
>> Args: [] (inspect_for_expectation_not_met_error at
>> /usr/local/lib/ruby/gems/1.8/gems/rspec-0.5.16/lib/spec/api/helper/ 
>> should_base.rb:10)
>> @params is deprecated! Call params.inspect instead of  
>> @params.inspect. Args:
>> [] (inspect_for_expectation_not_met_error at
>> /usr/local/lib/ruby/gems/1.8/gems/rspec-0.5.16/lib/spec/api/helper/ 
>> should_base.rb:10)
>> @flash is deprecated! Call flash.inspect instead of  
>> @flash.inspect. Args: []
>> (inspect_for_expectation_not_met_error at
>> /usr/local/lib/ruby/gems/1.8/gems/rspec-0.5.16/lib/spec/api/helper/ 
>> should_base.rb:10)
>> @session is deprecated! Call session.inspect instead of  
>> @session.inspect.
>> Args: [] (inspect_for_expectation_not_met_error at
>> /usr/local/lib/ruby/gems/1.8/gems/rspec-0.5.16/lib/spec/api/helper/ 
>> should_base.rb:10)
>> @flash is deprecated! Call flash.inspect instead of  
>> @flash.inspect. Args: []
>> (inspect_for_expectation_not_met_error at
>> /usr/local/lib/ruby/gems/1.8/gems/rspec-0.5.16/lib/spec/api/helper/ 
>> should_base.rb:10)
>> @params is deprecated! Call params.inspect instead of  
>> @params.inspect. Args:
>> [] (inspect_for_expectation_not_met_error at
>> /usr/local/lib/ruby/gems/1.8/gems/rspec-0.5.16/lib/spec/api/helper/ 
>> should_base.rb:10)
>> @session is deprecated! Call session.inspect instead of  
>> @session.inspect.
>> Args: [] (inspect_for_expectation_not_met_error at
>> /usr/local/lib/ruby/gems/1.8/gems/rspec-0.5.16/lib/spec/api/helper/ 
>> should_base.rb:10)
>> @params is deprecated! Call params.inspect instead of  
>> @params.inspect. Args:
>> [] (inspect_for_expectation_not_met_error at
>> /usr/local/lib/ruby/gems/1.8/gems/rspec-0.5.16/lib/spec/api/helper/ 
>> should_base.rb:10)
>> @flash is deprecated! Call flash.inspect instead of  
>> @flash.inspect. Args: []
>> (inspect_for_expectation_not_met_error at
>> /usr/local/lib/ruby/gems/1.8/gems/rspec-0.5.16/lib/spec/api/helper/ 
>> should_base.rb:10)
>> @session is deprecated! Call session.inspect instead of  
>> @session.inspect.
>> Args: [] (inspect_for_expectation_not_met_error at
>> /usr/local/lib/ruby/gems/1.8/gems/rspec-0.5.16/lib/spec/api/helper/ 
>> should_base.rb:10)
>> @params is deprecated! Call params.inspect instead of  
>> @params.inspect. Args:
>> [] (inspect_for_expectation_not_met_error at
>> /usr/local/lib/ruby/gems/1.8/gems/rspec-0.5.16/lib/spec/api/helper/ 
>> should_base.rb:10)
>> @flash is deprecated! Call flash.inspect instead of  
>> @flash.inspect. Args: []
>> (inspect_for_expectation_not_met_error at
>> /usr/local/lib/ruby/gems/1.8/gems/rspec-0.5.16/lib/spec/api/helper/ 
>> should_base.rb:10)
>>
>> Cheers
>> Luke
>>
>>
>> _______________________________________________
>> Rspec-devel mailing list
>> Rspec-devel at rubyforge.org
>> http://rubyforge.org/mailman/listinfo/rspec-devel
>>
>>
> _______________________________________________
> Rspec-devel mailing list
> Rspec-devel at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-devel



More information about the Rspec-devel mailing list