[Ros-talk] [Fwd: lookup experiment]

Simon Strandgaard neoneye at adslhome.dk
Fri Dec 26 13:08:30 EST 2003

On Fri, 2003-12-26 at 12:43, Shasckaw wrote:
> From: Shasckaw <shasckaw at skynet.be>
> To: Ruby Operating System <ros-talk at rubyforge.org>
> Subject: lookup experiment
> Date: 26 Dec 2003 12:38:23 +0100
> In AbstractSyntax.rb , the method name "accept" is not evocative enough. 
> Wouldn't it be better to name it "visit"?

I use the visitor design pattern. It is standard to name that it
'accept'.  I don't intend to go against standards.
People whom are familiar with design patterns will scratch their heads
and wonder why I choose a non-standard name.

I stick with 'accept'.

Suggestions for other modifications, changes... etc. are of cause
welcome :-)

Simon Strandgaard

More information about the Ros-talk mailing list