[rjb-users] Daemonized mongrel causes Segmentation faults

rjb-users at rubyforge.org rjb-users at rubyforge.org
Fri Nov 16 09:39:45 EST 2007


Hi,

Now I'm trying to reproduce the problem, but in my environment,
daemon mongrel runs fine with rjb, so please inform me more details.
With my test environment is
ruby 1.8.6-pl110 x86 64-linux
Java build 1.6.0-b105
 with poi-2.5.1.jar (my rjb testing app is to produce excel files with
Jakarta -POI, but I suppose that the Java libraries are not concerned)
mongrel 1.1.1
daemons 1.0.9
rjb 1.0.11
rails 1.2.3
Linux 2.6.20 (Ubuntu 4.1.2)

Regards

On Thu, 15 Nov 2007 20:36:20 +0100
rjb-users at rubyforge.orgさん wrote:

> Hello,
> 
> I already read that blog and used the memory configuration flags in the
> Rjb::load command, so the problem lies somewhere else.... Still, it is
> quite strange mongrel only crashes when being run as a daemon. It cannot
> be a user/right problem since I tried starting mongrel as the mongrel
> user, which works nicely without the -d.
> 
> Regards
> 
> rjb-users at rubyforge.org wrote:
> > Hi,
> >
> > Then, have you already read http://jaywhy.wordpress.com/2007/03/05/pdf-templates-via-rails/ ?
> > If you've not, then please read it.
> > I suppose that you can either set the options -Xms... in the code as
> > Rjb::load('', ['-Xms16m', '-Xmx32m'])
> >
> > Regards
> >
> > On Thu, 15 Nov 2007 16:46:15 +0100
> > rjb-users at rubyforge.orgさん wrote:
> >
> >   
> >> I already tried that solution. Procfs is mounted correctly and it is
> >> only a problem when running mongrel as a daemon. I recon if procfs was
> >> not mounted (or incorrectly) it should also have segfaulted in 'normal'
> >> mode.
> >>
> >> Regards
> >>
> >> rjb-users at rubyforge.org wrote:
> >>     
> >>> Hmmmm, interesting.
> >>>
> >>> http://forum.java.sun.com/thread.jspa?threadID=542672&messageID=2634141
> >>> I'm not sure the forum thread's result - just mounting linprocfs for you,
> >>> but please try it first.
> >>> And please let me know the result.
> >>>
> >>> Regards
> >>>
> >>> On Thu, 15 Nov 2007 12:24:43 +0100
> >>> rjb-users at rubyforge.orgさん wrote:
> >>>
> >>>
> >>>       
> >>>> Hello,
> >>>>
> >>>> I am currently trying to generate PDF's from ruby using iText. On my
> >>>> development machine everything worked fine. However when I moved to the
> >>>> production server (which uses mongrel_cluster), every instance of
> >>>> mongrel crashes when initializing the Java VM.
> >>>>
> >>>> When I started a server manually with 'sudo -u mongrel ruby
> >>>> script/server ......', generating PDF's worked again. However when I
> >>>> start the server as a daemon 'sudo -u mongrel ruby script/server -d
> >>>> ......' the instance crashes again with a segmentation fault. The line
> >>>> before the segmentation fault reads 'Java HotSpot(TM) 64-Bit Server VM
> >>>> warning: Can't detect initial thread stack location - find_vma failed'.
> >>>> The machine is a Intel Xeon system.
> >>>>
> >>>> Is this a known bug, and if so is there already a solution?
> >>>>
> >>>> Thanks in advance,
> >>>> Regards Andres
> >>>> _______________________________________________
> >>>> rjb-users mailing list
> >>>> rjb-users at rubyforge.org
> >>>> http://rubyforge.org/mailman/listinfo/rjb-users
> >>>>
> >>>>         
> >>> --
> >>> arton
> >>>
> >>>
> >>>       
> >
> > --
> > arton
> >
> >   
> 

-- 
arton



More information about the rjb-users mailing list