[rjb-users] Daemonized mongrel causes Segmentation faults

rjb-users at rubyforge.org rjb-users at rubyforge.org
Thu Nov 15 08:43:26 EST 2007

Hmmmm, interesting.

I'm not sure the forum thread's result - just mounting linprocfs for you,
but please try it first.
And please let me know the result.


On Thu, 15 Nov 2007 12:24:43 +0100
rjb-users at rubyforge.orgさん wrote:

> Hello,
> I am currently trying to generate PDF's from ruby using iText. On my 
> development machine everything worked fine. However when I moved to the 
> production server (which uses mongrel_cluster), every instance of 
> mongrel crashes when initializing the Java VM.
> When I started a server manually with 'sudo -u mongrel ruby 
> script/server ......', generating PDF's worked again. However when I 
> start the server as a daemon 'sudo -u mongrel ruby script/server -d 
> ......' the instance crashes again with a segmentation fault. The line 
> before the segmentation fault reads 'Java HotSpot(TM) 64-Bit Server VM 
> warning: Can't detect initial thread stack location - find_vma failed'. 
> The machine is a Intel Xeon system.
> Is this a known bug, and if so is there already a solution?
> Thanks in advance,
> Regards Andres
> _______________________________________________
> rjb-users mailing list
> rjb-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rjb-users


More information about the rjb-users mailing list