[rjb-users] can't create Java VM

rjb-users at rubyforge.org rjb-users at rubyforge.org
Sat Nov 10 08:52:29 EST 2007


Does Litespeed run in your permission ? In other words, it's launched in
/etc/init.d when the box is booting up ?
If so, you have to set JAVA_HOME and LD_LIBRAY_PATH in your startup
shell (/etc/init.d/litespeed etc, I don't know exact name).
If it's not the correct answer, please get the log after setting 
$DEBUG = true
on the first line of your config/environment.rb. And get the exception
information please.


On Sat, 10 Nov 2007 13:27:11 +0100
rjb-users at rubyforge.orgさん wrote:

> Hi,
> I have the following code:
> require 'rjb'
> Rjb::load('lib/itext-2.0.6.jar')
> When I run it under Windows, it works fine. But when I run it on my
> production Linux box, a get the error:
> can't create Java VM
> I did some searching on Google and it turns out, I have to set
> JAVA_HOME and LD_LIBRARY_PATH. I have set both variables in Linux and
> in my environment.rb file. But it still doesn't work. I'm using
> Litespeed as my webserver (so no Mongrel). Hope somebody can tell me
> what is wrong. Thanks.
> Kind regards,
> Nick
> _______________________________________________
> rjb-users mailing list
> rjb-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rjb-users


More information about the rjb-users mailing list