Line break bug?

Thomas Watson Steen twa at
Sat Apr 12 05:37:15 EDT 2008

On 12/04/2008, at 1.26, Thomas Watson Steen wrote:
> Thanks :)  - It worked like a charm. Now line-breaks are  
> interpreted as expected. I'll keep using this version and of cause  
> report any bugs I might find.

Well, it worked on my MacBook Pro running OS X 10.4
But on my staging and production server both running FreeBSD 6.2 I  
get the following error:
> [root at web01 ~]# gem install RedCloth --source http:// 
> Building native extensions.  This could take a while...
> ERROR:  Error installing RedCloth:
>         ERROR: Failed to build gem native extension.
> /usr/local/bin/ruby18 extconf.rb install RedCloth --source http:// 
> checking for main() in -lc... yes
> creating Makefile
> make
> cc -I. -I. -I/usr/local/lib/ruby/1.8/i386-freebsd6 -I.  -fPIC -O2 - 
> fno-strict-aliasing -pipe    -fPIC -O0 -c redcloth_inline.c
> cc -I. -I. -I/usr/local/lib/ruby/1.8/i386-freebsd6 -I.  -fPIC -O2 - 
> fno-strict-aliasing -pipe    -fPIC -O0 -c redcloth_scan.c
> cc1: out of memory allocating 637512112 bytes
> *** Error code 1
> Stop in /usr/local/lib/ruby/gems/1.8/gems/RedCloth-3.290/ext/ 
> redcloth_scan.
> Gem files will remain installed in /usr/local/lib/ruby/gems/1.8/ 
> gems/RedCloth-3.290 for inspection.
> Results logged to /usr/local/lib/ruby/gems/1.8/gems/RedCloth-3.290/ 
> ext/redcloth_scan/gem_make.out

I don't know exactly what happends when I install a gem, but it seems  
that some C code is compiled for the specific platform. I don't know  
if this bug is related to RedCloth at all, but I've been unsuccessful  
finding anybody on the web having the same problem. So I hope you  
might give me some pointers...

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 1936 bytes
Desc: not available
Url : 

More information about the Redcloth-upwards mailing list