[Rbrainz-users] Fwd: mb-discid issue with OS X

Derek Reeve dereknreeve at gmail.com
Wed Mar 31 20:48:31 EDT 2010


Hello,
I was the original person who asked the question; I didn't want to
spam the mailing list if I was doing something silly. Unfortunately,
after spending a few hours trying different things, I'm not having
much luck.

> The short answer that worked on my Snow Leopard: sudo gem install mb-discid -- --with-opt-dir=/usr/local
> You could argue that there should be a dir_config('discid') line in extconf.rb but since mb-discid only requires one external lib the opt option works just as well. If the dir_config option is
> added the following will also work: sudo gem install mb-discid -- --with-discid-dir=/usr/local

I tried the --with-opt-dir switch and I tried adding dir_config to
extconf.rb and installing the gem with --with-discid-dir, all with the
same results.
I apologize for my lack of knowledge, but is it possible OS X (I'm on
Snow Leopard too) can't find libdiscid, even though it's in
/usr/local/lib?
/usr/local/lib is definitely where the libraries are installed, but I
can't seem to get gem install to find libdiscid in this case.

I also tried updating extconf.rb with find_library('disc_id',
'discid_new', '/usr/local/lib') and ran extconf.rb. I got the same
error; I just thought I'd give it a shot.

Thanks for your continued help,
Derek


More information about the Rbrainz-users mailing list