[Rbrainz-users] Fwd: mb-discid issue with OS X

Nigel Graham nigel at maven-group.org
Wed Mar 31 09:27:58 EDT 2010

The short answer that worked on my Snow Leopard:
sudo gem install mb-discid -- --with-opt-dir=/usr/local

You could argue that there should be a dir_config('discid') line in extconf.rb but since mb-discid only requires one external lib the opt option works just as well.
If the dir_config option is added the following will also work:
sudo gem install mb-discid -- --with-discid-dir=/usr/local

Kind regards
- Nigel  

On 31/03/2010, at 09.49, Philipp Wolfer wrote:

> Hi,
> I'm forwarding the below message from a user to the list since I don't
> have a Mac to test this. Does anybody have an idea what the problem
> might be? Maybe the install script must check explicitly for
> libdiscid.dylib (on Windows it seemed to be necessary to check for
> libdiscid.dll)!?
> Thanks,
> Philipp
> ---------- Forwarded message ----------
> Date: Wed, Mar 31, 2010 at 4:40 AM
> Subject: mb-discid issue with OS X
> To: phw at rubyforge.org
> Greetings,
> I'm having trouble installing the mb-discid gem on OS X. My libdiscid
> is located in /usr/local/lib
> $ ls /usr/local/lib/libdiscid*
> /usr/local/lib/libdiscid.0.2.1.dylib  /usr/local/lib/libdiscid.a
> /usr/local/lib/libdiscid.la
> /usr/local/lib/libdiscid.0.dylib      /usr/local/lib/libdiscid.dylib
> but the "gem install" command still claims I don't have libdiscid:
> $ sudo gem install mb-discid
> Building native extensions.  This could take a while...
> ERROR:  Error installing mb-discid:
>         ERROR: Failed to build gem native extension.
> /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby extconf.rb
> checking for discid_new() in -ldiscid... no
> checking for discid_new() in -ldiscid.dll... no
> *** extconf.rb failed ***
> ...
> Required library libdiscid not found.
> I've tried a few different options:
> sudo gem install mb-discid -- --with-discidlib=/usr/local/lib
> But I'm not having very much luck. Am I doing something wrong? Any
> help would be greatly appreciated.
> For the record, I installed libdiscid from source on OS X and on
> Ubuntu; on Ubuntu, `sudo gem install mb-discid` seemed to work, but
> gives the
> LoadError: libdiscid.so.0: cannot open shared object file: No such
> file or directory -
> /usr/lib/ruby/gems/1.8/gems/mb-discid-0.1.4/lib/MB_DiscID.so
> error.
> Thank you for any help you can provide,
> _______________________________________________
> Rbrainz-users mailing list
> Rbrainz-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rbrainz-users

More information about the Rbrainz-users mailing list