[raleigh.rb] Noob deployment questions, part two

Sean Cribbs seancribbs at gmail.com
Sun Mar 15 19:24:53 EDT 2009


And you ran 'rake db:schema:load RAILS_ENV=production' ?

Sean

Thomas Ingram wrote:
> Okay, so I have one more question. I have almost everything worked out
> with that first deploy I asked about earlier. (By the way thank you
> all for your help!) Anyway all static pages on my staging server work,
> but I'm getting an error message on any page that requires database
> access. production.log indicates that the database has no tables,
> which I was able to confirm this with MySQL Query Browser. The obvious
> (to me) solution was to log into my server, cd to the application's
> current directory and run rake db:schema:load. That looked like it
> worked, based on the output onscreen, but after restarting everything,
> I'm still getting the same error. I made sure that db/schema.rb has
> all the table information, and it does. I found a blog mentioning cap
> log_deploy, but Capistrano says that is not a valid task.
>
> Can anyone tell me what's going on? Why can't I migrate my schema?
>
>   



More information about the raleigh-rb-members mailing list