[Rake-devel] Rake DSL Commands are no long in top level
alexch at gmail.com
Thu Jun 4 21:16:05 EDT 2009
> I'm not particularly attached to the patch it was done while sitting next to
> Jim at SoR. At the same time, I much prefer it to +desc+ in the general
> case, simply from a readability POV.
Really? I think the natural semantics for code comments is "these are
thrown away" so it's astonishing if they're used for anything
important. Having a named method in the DSL that means "this string
will be visible to end-users" is much more natural and readable to me.
Though "desc" is not the best name for this method -- how about
Or how about an attribute in the default hash for "task", e.g.
task :test, :description => "runs all tests" do
Speaking of which, it's always baffled and confounded me that only the
tasks whose authors had the presence of mind to add a "desc" show up
in "rake -T" or "rake -D". Can we make all tasks show up by default,
perhaps with an empty description, with perhaps an optional ":private
=> true" if you want to hide them?
More information about the Rake-devel