[Rake-devel] Multitask doesn't append scope to prereqs

Judson Lester nyarly at gmail.com
Tue Jul 21 17:40:21 EDT 2009


Right on.  I'll see about getting that back to you in a couple of days.

On Tue, Jul 21, 2009 at 1:00 PM, Jim Weirich <jim.weirich at gmail.com> wrote:

> On Jul 21, 2009, at 7:36 PM, Judson Lester wrote:
>
>  I discovered recently to my chagrin that tasks created with "multitask"
>> don't look for their prerequisites in the appropriate namespaces.  The fix
>> is incredibly simple and I think correct (unless there's an intended
>> semantic that multitask :task => :other_task should always search for
>> :other_task in the root namespace).
>>
>> I'd be happy to put a patch together - what's the preference for that?
>>
>
>
> A patch would be welcome.  The best option is a pull request from github
> (against the env branch).  Failing that, a regular patch file is acceptable
> (again, against the env branch is preferred).  Patches with test cases are
> looked upon with extreme favor.
>
> Recording a ticket at http://onestepback.org/redmine will help make sure
> it doesn't fall off my map.
>
> --
> -- Jim Weirich
> -- jim.weirich at gmail.com
>
> _______________________________________________
> Rake-devel mailing list
> Rake-devel at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rake-devel
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/rake-devel/attachments/20090721/a4cdf7f2/attachment.html>


More information about the Rake-devel mailing list