[Rake-devel] Status of

James M. Lawrence quixoticsycophant at gmail.com
Tue Jan 6 08:49:15 EST 2009

Now that 1.9 fixes the system() problem, there should be a
RUBY_VERSION check in Rake.  I just asked on ruby-core whether it will
be backported to 1.8 (probably not).  But we should wait to hear back.

The system() workaround has been simplified since the first pass
reflected in 8.3.100.  When we know which RUBY_VERSION to check, I'll
send a pull request.  Or you can pull my current mainline-rake branch
which assumes the 1.9 fixes won't be backported.

James M. Lawrence

More information about the Rake-devel mailing list