[Rake-devel] Problem with postgresql 8.2 database

Peter Hiltz bryan.emrys at gmail.com
Fri May 11 10:47:44 EDT 2007


Hi, possible newbie problem. 

Running rake version 0.7.3 (gem install, linux x86 box) against a postgreql 
8.2 database in rails.

The following error message turns up running commands such as:
rake routes -v --trace
rake db:schema:dump -v --trace
rake extract_fixtures -v --trace

Any suggestions would be appreciated.

Bryan

(in /var/www/localhost/htdocs/rails/railstax-dev)
** Invoke db:schema:dump (first_time)
** Invoke environment (first_time)
** Execute environment
NOTICE:  CREATE TABLE will create implicit 
sequence "aggregate_meta_datas_id_seq1" for serial 
column "aggregate_meta_datas.id"
rake aborted!
PGError: ERROR:  relation "aggregate_meta_datas" already exists
: CREATE TABLE aggregate_meta_datas ("id" serial primary key, "cube_name" 
character varying(255) DEFAULT NULL, "dimension1" character varying(255) 
DEFAULT NULL, "dimension1_hierarchy" character varying(255) DEFAULT 
NULL, "dimension2" character varying(255) DEFAULT 
NULL, "dimension2_hierarchy" character varying(255) DEFAULT 
NULL, "created_at" timestamp DEFAULT NULL, "populated_at" timestamp DEFAULT 
NULL)
/usr/lib64/ruby/gems/1.8/gems/activerecord-1.15.3/lib/active_record/connection_adapters/abstract_adapter.rb:128:in 
`log'
/usr/lib64/ruby/gems/1.8/gems/activerecord-1.15.3/lib/active_record/connection_adapters/postgresql_adapter.rb:152:in 
`execute'
/usr/lib64/ruby/gems/1.8/gems/activerecord-1.15.3/lib/active_record/connection_adapters/abstract/schema_statements.rb:104:in 
`create_table'
/var/www/localhost/htdocs/rails/railstax-dev/config/../vendor/plugins/activewarehouse/lib/active_warehouse/aggregate_meta_data.rb:8:in 
`build_table'
/var/www/localhost/htdocs/rails/railstax-dev/config/../vendor/plugins/activewarehouse/lib/active_warehouse/aggregate.rb:213
/usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in 
`gem_original_require'
/usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
/usr/lib64/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/dependencies.rb:495:in 
`require'
/usr/lib64/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/dependencies.rb:342:in 
`new_constants_in'
/usr/lib64/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/dependencies.rb:495:in 
`require'
/var/www/localhost/htdocs/rails/railstax-dev/config/../vendor/plugins/activewarehouse/lib/active_warehouse.rb:73
/usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in 
`gem_original_require'
/usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
/usr/lib64/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/dependencies.rb:495:in 
`require'
/usr/lib64/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/dependencies.rb:342:in 
`new_constants_in'
/usr/lib64/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/dependencies.rb:495:in 
`require'
/var/www/localhost/htdocs/rails/railstax-dev/config/../vendor/plugins/activewarehouse/init.rb:1:in 
`load_plugin'
/usr/lib64/ruby/gems/1.8/gems/rails-1.2.3/lib/initializer.rb:401:in 
`load_plugin'
/usr/lib64/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/core_ext/kernel/reporting.rb:11:in 
`silence_warnings'
/usr/lib64/ruby/gems/1.8/gems/rails-1.2.3/lib/initializer.rb:401:in 
`load_plugin'
/usr/lib64/ruby/gems/1.8/gems/rails-1.2.3/lib/initializer.rb:185:in 
`load_plugins'
/usr/lib64/ruby/gems/1.8/gems/rails-1.2.3/lib/initializer.rb:185:in `each'
/usr/lib64/ruby/gems/1.8/gems/rails-1.2.3/lib/initializer.rb:185:in 
`load_plugins'
/usr/lib64/ruby/gems/1.8/gems/rails-1.2.3/lib/initializer.rb:105:in `process'
/usr/lib64/ruby/gems/1.8/gems/rails-1.2.3/lib/initializer.rb:43:in `send'
/usr/lib64/ruby/gems/1.8/gems/rails-1.2.3/lib/initializer.rb:43:in `run'
/var/www/localhost/htdocs/rails/railstax-dev/config/../config/environment.rb:14
/usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in 
`gem_original_require'
/usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
/usr/lib64/ruby/gems/1.8/gems/rails-1.2.3/lib/tasks/misc.rake:3
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:392:in `call'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:392:in `execute'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:392:in `each'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:392:in `execute'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:362:in `invoke'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:355:in `synchronize'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:355:in `invoke'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:369:in 
`invoke_prerequisites'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1003:in `each'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1003:in `send'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1003:in `each'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:368:in 
`invoke_prerequisites'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:361:in `invoke'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:355:in `synchronize'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:355:in `invoke'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1739:in `top_level'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1739:in `each'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1739:in `top_level'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1761:in 
`standard_exception_handling'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1733:in `top_level'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1711:in `run'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1761:in 
`standard_exception_handling'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1708:in `run'
/usr/lib64/ruby/gems/1.8/gems/rake-0.7.3/bin/rake:7
/usr/bin/rake:16:in `load'
/usr/bin/rake:16
L, "dimension2_hierarchy" character varying(255) DEFAULT NULL, "created_at" 
timestamp DEFAULT NULL, "populated_at" timestamp DEFAULT NULL)



More information about the Rake-devel mailing list