[Rake-devel] Windows package task, windows cannot fork

Dominic Sisneros dsisnero at gmail.com
Tue Nov 14 20:28:37 EST 2006

---------- Forwarded message ----------
From: Dominic Sisneros <dsisnero at gmail.com>
Date: Nov 9, 2006 3:12 PM
Subject: windows xp package task
To: Rake Development and Discussion <rake-devel at rubyforge.org>

On windows, I use the GnuWin32 tar package.  When I try to use the package
task it gave me an error that windows cannot fork.  Looking online, I find
this blog post
has the following

Creating a zip package worked on the first try, but tar complained
that it *'Cannot
fork: Function not implemented' *. It turns out that Cygwin's tar can't run
gzip. So once again, it's time to fix the Rake source code. This time we're
talking about *rake/packagetask.rb*, line 117 that calls tar with the z
option. I replaced that one line with a separate call to tar and gzip:

 sh %{tar cvf #{package_name}.tar #{package_name}} if flag == 'z'   sh
%{gzip #{package_name}.tar} end

 You'll need to be a bit more fancy if you want to support both .tar.gz and
.tgz suffixes, but this little fix will allow you to create .tar.gz.

I did this and the package task worked.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/rake-devel/attachments/20061114/8936c1e2/attachment.html 

More information about the Rake-devel mailing list