[Rake-devel] Specifying a tar command for a GemPackageTask

Daniel Berger djberg96 at gmail.com
Mon Nov 6 11:20:18 EST 2006


Hi,

Ruby 1.8.5
Rake 0.7.1
Solaris 10

One of the issues I noticed for Rake::GemPackageTask is that it assumes GNU
tar.  If I do 'need_tar_gz = true' and try to run 'rake package' it will
fail because Solaris' tar doesn't support the -z option:

tar zcvf solaris-kstat-0.2.2.tar.gz solaris-kstat-0.2.2
tar: z: unknown function modifier
Usage: tar {c|r|t|u|x}[BDeEFhilmnopPqvw@[0-7]][bfk][X...] [blocksize]
[tarfile] [size] [exclude-file...] {file | -I include-file | -C directory
file}...
rake aborted!
Command failed with status (1): [tar zcvf solaris-kstat-0.2.2.tar.gzsolari...]

(See full trace by running task with --trace)

I do have gtar installed on this system, but I need a way to tell the
GemPackageTask to use it.  Is there a way to do that?  If not, can we add
it?

Thanks,

Dan
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/rake-devel/attachments/20061106/a8c985b5/attachment.html 


More information about the Rake-devel mailing list