[Rake-devel] Problem with rake's PackageTask

Leon leopardus.vulgaris at gmail.com
Sun Jan 22 05:42:44 EST 2006

Hello people,

I have a very strange problem with Rake's PackageTask library. It
doesn't work for me. I googled for some time with no results. I read
docs from http://rake.rubyforge.org/ and actually copied code from
there. Also I have seen all the relevant places this document mentions
with no success.

This is the part of my rakefile:
require 'rake/packagetask'
desc 'This will include package tasks'
Rake::PackageTask.new("webdesign", "0.1") do |p|
  p.need_zip = true

When I run rake --tasks I do not see package tasks at all.

My rake --version is "rake, 0.7.0"
My ruby --version is "ruby 1.8.3 (2005-09-21) [i686-linux]"
on gentoo linux

Please help me, I don't want to switch to ant for these simple tasks.


More information about the Rake-devel mailing list