[Rake-devel] MetaProject

aslak hellesoy aslak.hellesoy at gmail.com
Tue Sep 6 19:05:02 EDT 2005

On 9/5/05, Jim Weirich <jim at weirichhouse.org> wrote:
> On Thursday 01 September 2005 08:57 pm, aslak hellesoy wrote:
> > Hi all,
> >
> > (I also sent this to the RubyGems list)
> >
> > The past month I've been working on a project (MetaProject:
> > http://xforge.rubyforge.org/) that among other things includes a quick
> > release system (QRS) for (among other places) RubyForge.
> >
> > With MetaProject's Rake task, releasing new gems on RubyForge is a breeze:
> Aslak,
> I'm really excited about this project.  This will be a great help.
> Unfortunately, I has a few problems ...

Ouch, I'm sorry about that. Read on.

> (1) The CHANGES file couldn't be parsed, resulting in an error message and a
> stack dump ... but the rake file continued processing.  The message should
> clearly be labled a warning and the stack dump avoided unless the --trace
> option is given.  Even better would be a way of disabling CHANGES parsing.
> (I'm not sure why it was failing ... my format looks similar to yours,
> perhaps my version numbers weren't matching).

It could be that the version numbers weren't matching.

MetaProject::VersionParser now raises a detailed exception and
interrupts Rake if it can't parse the CHANGES file.

I have also added a FAQ (http://xforge.rubyforge.org/) that describes
how to disable parsing of the CHANGES file (in which case you have to
supply the release notes and changes in the Rakefile).

> (2) I wanted to enter the username/password interactively.  Unfortunately an
> undefined @host instance variable caused problems.  I worked around it with:
>   Host = Struct.new(:name)
>   release.instance_eval { @host = Host.new('RubyForge') }

Glitch on my part that is fixed now. (I have my env vars set in
.bashrc and this part doesn't have unit tests, so I never encountered

> (3) I got a "couldn't find package_id" message.  I enabled --trace on the rake
> command and got the following output.  I didn't follow it any farther ...


Yep, that was a bug that should be fixed now.

I have released MetaProject 0.4.8 that hopefully fixes all of the
problems you encountered. (I have only tried it, not proved it
correct! I haven't spent much time unit testing the rake task under
different conditions). Please let me know if it works/doesn't work for
you this time.

Thanks for testing it out and giving good feedback!


> -- Jim Weirich    jim at weirichhouse.org     http://onestepback.org
> -----------------------------------------------------------------
> "Beware of bugs in the above code; I have only proved it correct,
> not tried it." -- Donald Knuth (in a memo to Peter van Emde Boas)

More information about the Rake-devel mailing list