[Rake-devel] Can we make the rake class names more unique?

felkinator-ror at yahoo.com felkinator-ror at yahoo.com
Sun Aug 21 11:31:56 EDT 2005

I'm working with rails and trying to use migrations
with my app. One of the tables I need to migrate
happens to be named 'Task'. I spent a couple hours
yesterday trying to get my migration to work, which
was just a minor variation on the example from the
documentation. It appears the reason is a name space
collision -- I was expecting an 'ActiveRecord' Task,
but I was getting the Rake Task. 

How about changing Task to RakeTask, or RkTask, or
something like that? How about adding a prefix to all
rake internal classes? Is there another better



More information about the Rake-devel mailing list