[Rake-devel] Separate TGZ and GEM packages?

Gavin Sinclair gsinclair at soyabean.com.au
Tue Oct 12 08:37:30 EDT 2004


On Tuesday, October 12, 2004, 1:47:58 AM, Jim wrote:


> Gavin Sinclair said:
>> Jim,
>>
>> I can't see a way in Rake to create GEM and TGZ package tasks with
>> different file sets.  The one file I want to differentiate on is
>> 'setup.rb'.  It's not needed for a gem, and at nearly 30Kb it's
>> best avoided if possible.

> currently there is not a way to do that with a single package task suite.

> Perhaps you can setup two package task suites, one a gem one with need_tar
> and need_zip set to false.  Then a second non-gem package task suite
> identical to gem one but with the added setup.rb in the files list.  Hmmm
> ... gem packages and non-gem packages don't share the same setup because
> the gem version pulls the information from the gem spec.  That might take
> some kluging.

> Warning: I've not tried the above, but it might be worthwhile investigating.

To be honest, it makes my head spin.  Two separate packaging tasks
with different names (like RDocTask allows) would do the trick.  It's
easy to reuse a general FileList and tinker with it as necessary.

I guess I would call them 'pkg_gem' and 'pkg_tgz'.

> An Aside:  Notice the purposeful injection of the work "suite" into the
> above.  I've been searching for a word to describe the PackageTask class
> (and its relatives).  Initially I called them task libraries, but that
> didn't seem to fit exactly (if I need to talk about the library where
> PackageTask is located, then I need to say task library library ... yuck).

> I'm thinking about using the word "suite" to describe PackageTask, so I'm
> trying it out here.  Thoughts?  (I've also got some other ideas I need to
> writeup and get out on this list for feedback).

That's fine, but I don't see why the word suite is particularly
appropriate.

I'm certainly looking forward to any written thoughts you have.

Cheers,
Gavin





More information about the Rake-devel mailing list