Error building Zbatery on Windows

Eric Wong normalperson at
Wed Sep 7 16:26:40 EDT 2011

Gavin Kistner <gkistner at> wrote:
> Fetching: kgio-2.6.0.gem (100%)
> Temporarily enhancing PATH to include DevKit...
> Building native extensions.  This could take a while...
> ERROR:  Error installing zbatery:
>         ERROR: Failed to build gem native extension.

kgio doesn't support non-Free systems.  Maybe pre-kgio-dependent
versions of Zbatery did, but we've never heard reports either way.

Zbatery should always work on MMU-less platforms without fork()
support, though I haven't had a chance to try.

Eric Wong

More information about the rainbows-talk mailing list