problem with rainbows 3.2.0 and rbx

Mike Perham mperham at
Sat Apr 30 12:10:43 EDT 2011

I just used my OSX system ruby and gems (had to update rubygems to use
bundler), same result:

> ruby -v
ruby 1.8.7 (2009-06-12 patchlevel 174) [universal-darwin10.0]
> gem -v

`init_worker_process': no such file to load -- rainbows/response
	from /Users/mperham/.gem/ruby/1.8/gems/rainbows-3.2.0/lib/rainbows/thread_pool.rb:26:in
	from /Users/mperham/.gem/ruby/1.8/gems/unicorn-3.6.2/lib/unicorn/http_server.rb:509:in
	from /Users/mperham/.gem/ruby/1.8/gems/unicorn-3.6.2/lib/unicorn/http_server.rb:507:in
	from /Users/mperham/.gem/ruby/1.8/gems/unicorn-3.6.2/lib/unicorn/http_server.rb:507:in
	from /Users/mperham/.gem/ruby/1.8/gems/unicorn-3.6.2/lib/unicorn/http_server.rb:503:in

On Fri, Apr 29, 2011 at 6:19 PM, Eric Wong <normalperson at> wrote:
> Mike Perham <mperham at> wrote:
>> To follow up, this was with Rubygems 1.6.2 and rbx 1.2.4dev.  I get
>> the exact same error with Rubygems 1.7.2 and Ruby 1.9.2.
> I'm definitely not seeing this with Rubygems 1.7.2 and Ruby 1.9.2-p180,
> that's my usual environment and I have a couple of private servers
> running that (no dev installs from setup.rb that could pollute
> Have you tried this without RVM?
> --
> Eric Wong
> _______________________________________________
> Rainbows! mailing list - rainbows-talk at
> Do not quote signatures (like this one) or top post when replying

More information about the rainbows-talk mailing list