bumping Rainbows! version requirements?

Eric Wong normalperson at yhbt.net
Fri Jun 18 15:05:29 EDT 2010

Hi all,

Given our lack of current users, maintaining backwards compatibility
with old things isn't something I want to spend too much time on.

* Any objections to dropping Ruby 1.8.6 support?

  I believe most folks are on 1.8.7, and 1.9.2 adoption should go up
  with Rails 3.

* Any objections to requiring Rack 1.1.0 or later?

  Some Rails 2.3.x versions were pinned to Rack 1.0.x, but for
  the most part 1.1.0 and 1.2.1 are backwards-compatible.
  Rails 2.2.x and earlier (using Unicorn::App::OldRails)
  is actually more compatible with newer Rack versions than
  all but the latest Rails 2.3.x versions.

This is only for Rainbows!/Zbatery and will NOT affect Unicorn.

Eric Wong

More information about the rainbows-talk mailing list