[Nitro] Og CRUD naming of methods

George Moschovitis george.moschovitis at gmail.com
Sat Sep 29 09:19:20 EDT 2007

I more or less agree with consistent naming. But, I am afraid this
will have to wait for a later version.

thanks for this *useful* post,

On 9/29/07, Mark Van De Vyver <mvyver at gmail.com> wrote:
> Hi Devs
> In [./manager.rb:initialize]
> @store_class.allocate.destroy_db(@options) if
> Og.destroy_schema||@options[:destroy]
> and elsewhere there is this:
>   alias_method :destroy, :drop_table
>   alias_method :drop_schema, :drop_schema
> Despite the typo (in the last alias) it seems there is confusion in
> the code about whether a schema is a db or table...
> Is it worth articulating following goal for Og to progress to?
> To use C.R.U.D stubs to method names. so prepend:
> create, read update, delete
> to the following
> *_db
> *_table
> *_row
> *_field
> I also think the abundance of aliases might hurt in the longer term -
> it's driving me nuts.  Accepting there may be some pain to adopt these
> conventions, but won't it help to have a consistent naming convention
> that you don't have to scramble to the docs to check: 'Is it destroy,
> drop, delete, table, tbl, schema, etc?"
> my 2c after a frustrating few days :)
> _______________________________________________
> Nitro-general mailing list
> Nitro-general at rubyforge.org
> http://rubyforge.org/mailman/listinfo/nitro-general


More information about the Nitro-general mailing list