[Nitro] Og CRUD naming of methods
Mark Van De Vyver
mvyver at gmail.com
Fri Sep 28 21:11:22 EDT 2007
and elsewhere there is this:
alias_method :destroy, :drop_table
alias_method :drop_schema, :drop_schema
Despite the typo (in the last alias) it seems there is confusion in
the code about whether a schema is a db or table...
Is it worth articulating following goal for Og to progress to?
To use C.R.U.D stubs to method names. so prepend:
create, read update, delete
to the following
I also think the abundance of aliases might hurt in the longer term -
it's driving me nuts. Accepting there may be some pain to adopt these
conventions, but won't it help to have a consistent naming convention
that you don't have to scramble to the docs to check: 'Is it destroy,
drop, delete, table, tbl, schema, etc?"
my 2c after a frustrating few days :)
More information about the Nitro-general