[Nitro] nitro build fails on OSX and Ubuntu with gem errors

George Moschovitis george.moschovitis at gmail.com
Tue Sep 18 08:17:45 EDT 2007


Let me try to give you some quick help. I will try to provide a better
solution later today.

Get the latest version from the repository.

make sure you have the following gems installed:

facets-1.8.54             <---------- Notice the version!!
RedCloth-3.0.4
hpricot-0.6
mysql-2.7
xml-simple-1.0.11

add something like this to your .bashrc file

export RUBYOPT="-rubygems -I/home/gmosx/code/public/nitro/lib
-I/home/gmosx/code/public/nitro/vendor
-I/home/gmosx/code/public/og/lib -I/home/gmosx/code/public/glue/lib
-I/home/gmosx/code/public/raw/lib

then run the blog example

$ cd examples/blog
$ vi conf/debug.rb     <---- customize
$ nitro



hope this will work for you.


-g.


-- 
http://www.me.gr
http://phidz.com
http://blog.gmosx.com
http://cull.gr
http://www.joy.gr
http://nitroproject.org


More information about the Nitro-general mailing list