[Nitro] nitro build fails on OSX and Ubuntu with gem errors

Dan North dan at tastapod.com
Tue Sep 18 08:05:21 EDT 2007

Hi folks.

So I'm telling people at RailsConf about nitro (they're making a funny 
looping knot in a long piece of rope - I wonder what that's for..?), and 
in particular trying to show it to one of the jruby guys.

He pulled down the latest darcs head (having built darcs on his macbook 
which took about 6 hours  - maybe we should consider mercurial?) and 
tried to rake test:all - it breaks all over the place. Not a good first 

I tried the same on ubuntu and it breaks in the same way.

I managed to get it working on my machine by setting GEM_HOME (which 
incidentally fixed a bunch of other stuff for me too). On his machine it 
still doesn't run through properly. Also, if the gems are installed in 
the correct place relative to your ruby installation, you shouldn't even 
need GEM_HOME, so the nitro build is definitely borked.

Can someone who knows how the build works take a look please? Also, if 
we're using rspec now, we can switch to the standard spec task which 
should fix a lot of this.


More information about the Nitro-general mailing list