[Nitro] Sporadic 'Found altered cookie' errors

George Moschovitis george.moschovitis at gmail.com
Thu Sep 6 04:03:58 EDT 2007

I have noticed this. This has to do with the new cookie based session system
that is used by default.
This looks like a serious bug, will have to look at this more closely. I
would really appreciate it if someone could have a look at


and perhaps offer some ideas.

In the meantime, how about using the memory session store for your  tests?


On 9/6/07, Bill Kelly <billk at cts.com> wrote:
> Hi,
> Is anyone else getting sporadic 'Found altered cookie'
> errors in their logs?
> At first I thought it was just related to the haphazard
> way I was refreshing my pages during development.  But now
> that I'm using WWW::Mechanize to test my site, it's also
> randomly seeing these cookie errors.
> I somehow doubt FireFox and WWW::Mechanize have the same
> bug in their cookie handling, so ... it seems something on
> the server-side is having issues.
> I'll continue debugging, but I just wondered if anyone else
> has been seeing this?
> (Note: I never noticed this problem on Nitro 0.31 ... it
> only started after I ported my code to the repo version...)
> Thanks,
> Bill
> _______________________________________________
> Nitro-general mailing list
> Nitro-general at rubyforge.org
> http://rubyforge.org/mailman/listinfo/nitro-general

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/nitro-general/attachments/20070906/70e2d7ef/attachment.html 

More information about the Nitro-general mailing list