[Nitro] Og tests helper

Arne Brasseur arne at arnebrasseur.net
Mon Sep 3 04:59:00 EDT 2007


I'm trying to reproduce this here so I can better understand the issue. 
Is there a preferred way to tell the og tests about my MySql configuration?

(ab)

George Moschovitis schreef:
> Dear devs,
>
> I have a little problem with the rspec infrastructure 'borrowed' from 
> Ramaze.
>
> when I run the (few) og tests with
>
> rake test:og
>
> I get:
>
> (in /home/gmosx/code/public)
> Running og...                    [   1 specs -   0 failed ]
> Running og/store/sql...          [   1 specs -   0 failed ]
> Running og/validation...         [   1 specs - all passed ]
> -------------------------------------[ og 
> ]-------------------------------------
> ExitStatus:
> #<Process::Status: pid=13203,exited(0)>
> StdOut:
> Database "test" dropped
> .
>
> Finished in 0.136994 seconds
>
> 1 example, 0 failures
>
> The problem seems to be that the system command used to drop the 
> database before each test. It seems to trigger the error code in 
> script/lib/wrap.rb...
>
> If you run the tests one by one they work.
>
> Michael, Jonathan, Arne, do you have any idea?
>
> -g.
>
>
> -- 
> http://www.me.gr
> http://phidz.com
> http://blog.gmosx.com
> http://cull.gr
> http://www.joy.gr
> http://nitroproject.org <http://nitroproject.org>
> ------------------------------------------------------------------------
>
> _______________________________________________
> Nitro-general mailing list
> Nitro-general at rubyforge.org
> http://rubyforge.org/mailman/listinfo/nitro-general


-- 
Arne Brasseur
http://www.arnebrasseur.net
arne at arnebrasseur.net

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/nitro-general/attachments/20070903/5ca8bba9/attachment-0001.html 


More information about the Nitro-general mailing list