[Nitro] Og [RFC]: More jargon...

Mark Van De Vyver mvyver at gmail.com
Sun Oct 7 06:33:17 EDT 2007


addendum:

On 10/7/07, Mark Van De Vyver <mvyver at gmail.com> wrote:
> Hi Devs,
> Votes please...
>
> On 10/7/07, George Moschovitis <george.moschovitis at gmail.com> wrote:
> >
> > > IMHO they certainly don't write or read, it's debatable that some
> > >
> >
> > in lisp literature reading == parsing. In this point of view read is a valid
> > prefix.
> > I chose them because read has the same stringlength with write and makes
> > the source code nicer ;-)
> >
> > but as I said, I fully agree with you that naming consistency is important.
>
> Currently we have methods named:
> parse_attr_<klass>
> write_attr_<klass>
>
>
> Are any of the following name pairs preferred?:
>
> deconstruct_attr_<klass>
> construct_attr_<klass>
>
> decompose_attr_<klass>
> compose_attr_<klass>
>
> disassemble_attr_<klass>
> assemble_attr_<klass>

marshall_attr_<klass>
unmarshall_attr_<klass>

Thanks
Mark
>
>
> > -g.
> >
> > --
> > http://gmosx.me.gr
> > http://phidz.com
> > http://blog.gmosx.com
> > http://cull.gr
> > http://www.joy.gr
> > http://nitroproject.org
>


More information about the Nitro-general mailing list