[Nitro] Og [patch]: Rename write_attr_<class> to serialize_attr_<class>

Mark Van De Vyver mvyver at gmail.com
Fri Oct 5 04:57:22 EDT 2007


On 10/5/07, George Moschovitis <george.moschovitis at gmail.com> wrote:
> I kind of like
>
> read_attr
> write_attr

I haven't touch write_attr  -  yet :)

if you're still not convinced let me know I'll try and explain why.
Mark


> (notice the symmetry)
>
> -g.
>
>
> On 10/5/07, Mark Van De Vyver < mvyver at gmail.com> wrote:
> >
> > These changes should have no effect at the users level?
> >
> > * Rename write_attr_<class> to serialize_attr_<class>
> >   These names properly reflect what is happening.  Renaming is also a
> > precursor to some changes that 1) DRY out the serialization that
> > occurs in Og, 2) Should permit Og's type mapping to be extensible
> > (without touching the code).
> >
> > _______________________________________________
> > Nitro-general mailing list
> > Nitro-general at rubyforge.org
> > http://rubyforge.org/mailman/listinfo/nitro-general
> >
> >
>
>
>
> --
> http://gmosx.me.gr
> http://phidz.com
>  http://blog.gmosx.com
> http://cull.gr
> http://www.joy.gr
> http://nitroproject.org


More information about the Nitro-general mailing list