[Nitro] Running branch

Trans transfire at gmail.com
Sat Nov 24 20:16:27 EST 2007



On Nov 24, 8:06 pm, Arne Brasseur <a... at arnebrasseur.net> wrote:
> The current branch of Nitro is supposed to run with the SVN versions of
> facets, english, blow and opod, right?
>
> I got it working but I'm just checking because I had to comment out a
> bunch of require statements before it would work. I suppose these are
> leftovers from the old facets layout?
>
> plexus at plexus-laptop:~/work/nitro_repo$ darcs diff
> diff -rN old-nitro_repo/glue/lib/glue/aspects.rb
> new-nitro_repo/glue/lib/glue/aspects.rb
> 15c15
> < # after :read, do
> ---
>  > # after :read do
> diff -rN old-nitro_repo/glue/lib/glue/main.rb
> new-nitro_repo/glue/lib/glue/main.rb
> 17,18c17,18
> < require "facets/module/is"
> < require "facets/class/cattr"
> ---
>  > #require "facets/module/is"
>  > #require "facets/class/cattr"
> diff -rN old-nitro_repo/og/lib/og/store/sql.rb
> new-nitro_repo/og/lib/og/store/sql.rb
> 1,2c1,2
> < require "facets/module/ancestor"
> < require "facets/class/subclasses"
> ---
>  > #require "facets/module/ancestor"
>  > #require "facets/class/subclasses"
> diff -rN old-nitro_repo/raw/lib/raw/compiler/filter/elements/element.rb
> new-nitro_repo/raw/lib/raw/compiler/filter/elements/element.rb
> 4c4
> < require "facets/string/capitalized"
> ---
>  > #require "facets/string/capitalized"
> 6c6
> < require "facets/dir/recurse"
> ---
>  > #require "facets/dir/recurse"
> diff -rN old-nitro_repo/raw/lib/raw/context.rb
> new-nitro_repo/raw/lib/raw/context.rb
> 1,2c1,2
> < require "facets/kernel/assign_with"
> < require "facets/module/is"
> ---
>  > #require "facets/kernel/assign_with"
>  > #require "facets/module/is"
> diff -rN old-nitro_repo/raw/lib/raw/controller/caching.rb
> new-nitro_repo/raw/lib/raw/controller/caching.rb
> 5c5
> < require "facets/kernel/eigenclass"
> ---
>  > #require "facets/kernel/eigenclass"
> diff -rN old-nitro_repo/raw/lib/raw/dispatcher.rb
> new-nitro_repo/raw/lib/raw/dispatcher.rb
> 2c2
> < require "facets/module/ancestor"
> ---
>  > #require "facets/module/ancestor"
> diff -rN old-nitro_repo/raw/lib/raw/util/xml.rb
> new-nitro_repo/raw/lib/raw/util/xml.rb
> 3c3
> < require "facets/kernel/assign_with"
> ---
>  > #require "facets/kernel/assign_with"

Hmm... that should not have been necessary. How did you install the
latest Facets?

T.


More information about the Nitro-general mailing list