[Nitro] script/ vs helper/ vs script/helper

George Moschovitis george.moschovitis at gmail.com
Fri Jun 22 05:50:48 EDT 2007


>
> specific reasons to use a home made script for this, or can we consider
> this redundant?


if you think that darcs replace does the same then lets get rid of this.

helper/glycerin.rb
> helper/spec.rb
> helper/layout.rb
> helper/wrap.rb
>
> Layout and wrap are used for the specs, and I can imagine other spec
> helpers appearing. So why not move layout and wrap to a spec subdir,
>
> helper/glycerin.rb
> helper/spec.rb
> helper/spec/layout.rb
> helper/spec/wrap.rb
>
> Additional rspec helper stuff could go in there, e.g. I wrote a custom
> Rspec::Matcher to be able to write
> day.should be_in(1..31)
> in stead of
> (1..31).should include day
>
> That would go in helper/spec/in.rb, and be included from helper/spec.rb.
> Nice and clean :)



i don't like the name helper... btw, will the script  directory dissapear?


-- 
http://phidz.com
http://blog.gmosx.com
http://cull.gr
http://www.joy.gr
http://nitroproject.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/nitro-general/attachments/20070622/910003c2/attachment.html 


More information about the Nitro-general mailing list