[Nitro] Error when using lighttpd + Nitro file caching

George Moschovitis george.moschovitis at gmail.com
Wed Jan 10 16:42:52 EST 2007


hmm, I haven't ever used the file caching with sessions to tell you the
truth. Perhaps someone else has more experience with this?

-g.

On 1/10/07, Lars Olsson <lasso at lassoweb.se> wrote:
>
> Hi list!
>
> I often get the error below when using lighttpd + Nitro file caching.
> Nitro is obviously looking for a non-existing cache file...Have anyone
> else experienced something similar and maybe worked around the problem?
>
> Sincerely
>
> /lasso
>
>
>
> ERROR: Error while handling '/'.
> ERROR: No such file or directory -
> /tmp/nitro_file_cache/session_nsid/9fc7781f0b49443b32855bf3f191dbf0
>    /usr/lib/ruby/gems/1.8/gems/glue-0.40.0/lib/glue/cache/file.rb:63:in
> `initialize'
>    /usr/lib/ruby/gems/1.8/gems/glue-0.40.0/lib/glue/cache/file.rb:63:in
> `encode_file'
>    /usr/lib/ruby/gems/1.8/gems/glue-0.40.0/lib/glue/cache/file.rb:20:in
> `[]='
>    /usr/lib/ruby/gems/1.8/gems/nitro-0.40.0/lib/nitro/session.rb:110:in
> `lookup'
>    /usr/lib/ruby/gems/1.8/gems/nitro-0.40.0/lib/nitro/context.rb:126:in
> `session'
> /usr/lib/ruby/gems/1.8/gems/nitro-0.40.0/lib/nitro/render.rb:260:in
> `session'
>    /usr/lib/ruby/gems/1.8/gems/nitro-0.40.0/lib/nitro/flash.rb:144:in
> `flash'
>    (eval):5:in `index_action'
>    /usr/lib/ruby/gems/1.8/gems/nitro-0.40.0/lib/nitro/render.rb:128:in
> `render'
>    /usr/lib/ruby/gems/1.8/gems/nitro-0.40.0/lib/nitro/cgi.rb:56:in
> `process'
>
> /usr/lib/ruby/gems/1.8/gems/nitro-0.40.0
> /lib/nitro/adapter/fastcgi.rb:40:in
> `start'
>
> /usr/lib/ruby/gems/1.8/gems/nitro-0.40.0
> /lib/nitro/adapter/fastcgi.rb:38:in
> `start'
>
> /usr/lib/ruby/gems/1.8/gems/nitro-0.40.0/lib/nitro/server/runner.rb:264:in
> `invoke'
>    /usr/lib/ruby/gems/1.8/gems/nitro-0.40.0/lib/nitro/server.rb:151:in
> `run'
>    /usr/lib/ruby/gems/1.8/gems/nitro-0.40.0/lib/nitro.rb:77:in `run'
>    /home/lassoweb/nitro_sites/lassoweb/run.rb:4
>    /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in `require'
>    /home/lassoweb/nitro_sites/lassoweb/public/dispatch.fcgi:4
>    LOGGED FROM:
> /usr/lib/ruby/gems/1.8/gems/nitro-0.40.0/lib/nitro/render.rb:251:in
> `log_error'
>
> --
> ________________________________________
> Lars Olsson
> lasso at lassoweb.se
> http://www.lassoweb.se/
>
> _______________________________________________
> Nitro-general mailing list
> Nitro-general at rubyforge.org
> http://rubyforge.org/mailman/listinfo/nitro-general
>



-- 
http://blog.gmosx.com
http://cull.gr
http://www.joy.gr
http://nitroproject.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/nitro-general/attachments/20070110/a047ca14/attachment.html 


More information about the Nitro-general mailing list