[Nitro] Darcs troubles

Judson Lester nyarly at gmail.com
Mon Feb 12 15:11:30 EST 2007

I'm an admitted novice with Darcs.  Right now, I feel clumsy with it,
and more importantly, patches I submit using it can't be applied.  Can
anyone suggest what I'm doing wrong?  Very likely I'm still in the
realm of common gotchas.

Twice now I've finished doing some edits, done a darcs record, a pull,
resolved some conflicts, recorded, and then a send.  The resulting
bundle won't apply.  I think one of them might?  But I think my first
bundle hung George's darcs when he tried to apply it, and the main
repo hung my darcs when I tried to pull.  (I since believe that had to
do with working under a soft link into my local repo - which isn't
thrilling behavior.)

Is this a symptom of something?  What am I doing wrong?

On a related note, can I tell darcs to use an external merger?  I find the
default behavior of clobbering source files mostly just confusing.


More information about the Nitro-general mailing list