[Nitro] Install your own Nitro dev-branch gems!

Arne Brasseur arne at arnebrasseur.net
Sat Dec 8 03:17:38 EST 2007


Matthew B Gardner schreef:
> I required rubygems (sorry, I thought I had tried that before, but maybe only 
> with nitro_and_og), but I still have the FormHelper name error.
>
> ./app/controller/root.rb:2: uninitialized constant RootController::FormHelper 
> (NameError)
>         from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in 
> `require'
>         from app.rb:7
>
> Looks like I did all this for nothing :). Do I just need to require a file to 
> get around this problem?
>
>   
module FormHelper is defined in view/nform, so

  require "view/nform"

might do the trick. If you still get the same problem try fully 
qualifying it:

  include Raw::FormHelper

Thanks for trying the tutorial and reporting this.

(ab)

> Thanks again again,
> Matt
>
> On Saturday 08 December 2007 01:30, Arne Brasseur wrote:
>   
>> Matthew B Gardner schreef:
>>     
>>> I actually tried that too...sorry, I should have included that info.
>>>
>>> app.rb:3:in `require': no such file to load -- nitro (LoadError)
>>>         from app.rb:3
>>>
>>> I didn't have this problem before I switched to the darcs approach (I
>>> switched b/c of the FormHelper name error).
>>>       
>> So are you installing the gems or running the repo the directly? In the
>> first case add require "rubygems" or use the RUBYOPT=-rubygems trick.
>>     
> _______________________________________________
> Nitro-general mailing list
> Nitro-general at rubyforge.org
> http://rubyforge.org/mailman/listinfo/nitro-general
>
>   


-- 
Ein Fuchs muß tun, was ein Fuchs tun muß
arne at arnebrasseur.net

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/nitro-general/attachments/20071208/8901c1c0/attachment-0001.html 


More information about the Nitro-general mailing list