[Nitro] Install your own Nitro dev-branch gems!

Matthew B Gardner weather at speakeasy.net
Sat Dec 8 01:53:46 EST 2007


I required rubygems (sorry, I thought I had tried that before, but maybe only 
with nitro_and_og), but I still have the FormHelper name error.

./app/controller/root.rb:2: uninitialized constant RootController::FormHelper 
(NameError)
        from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in 
`require'
        from app.rb:7

Looks like I did all this for nothing :). Do I just need to require a file to 
get around this problem?

Thanks again again,
Matt

On Saturday 08 December 2007 01:30, Arne Brasseur wrote:
> Matthew B Gardner schreef:
> > I actually tried that too...sorry, I should have included that info.
> >
> > app.rb:3:in `require': no such file to load -- nitro (LoadError)
> >         from app.rb:3
> >
> > I didn't have this problem before I switched to the darcs approach (I
> > switched b/c of the FormHelper name error).
>
> So are you installing the gems or running the repo the directly? In the
> first case add require "rubygems" or use the RUBYOPT=-rubygems trick.


More information about the Nitro-general mailing list