[Nitro] gem_original_require': no such file to load -- blow/json (LoadError)

Arne Brasseur arne at arnebrasseur.net
Thu Dec 6 02:14:30 EST 2007


Reid Thompson schreef:
> On Wed, 2007-12-05 at 10:00 -0800, Trans wrote:
>   
> Thanks,,....
> next issue...
>
> rthompso at raker ~/src/repo.nitroproject.org/nitro/demo/blog $ ruby ./app.rb
> REPO_ROOT is /home/rthompso/src/repo.nitroproject.org/script/lib/../..
> /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require': no such file to load -- part/admin (LoadError)
>         from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
>         from ./app.rb:11
>   
Try this:

RUBYOPT="-rubygems -I$NITRO_HOME" ruby app.rb

(ab)

> rthompso at raker ~/src/repo.nitroproject.org/nitro/demo/blog $ env|grep -i NITRO
> OLDPWD=/home/rthompso/src/repo.nitroproject.org
> NITRO_HOME=/home/rthompso/src/repo.nitroproject.org
> PATH=/home/rthompso/src/repo.nitroproject.org/nitro/bin:/home/rthompso/bin:/usr/lib/ccache/bin:/usr/lib/ccache/bin:/usr/local/bin:/usr/bin:/bin:/opt/bin:/usr/i686-pc-linux-gnu/gcc-bin/4.1.2:/opt/ghc/bin:/usr/kde/3.5/bin:/usr/qt/3/bin:/opt/Adbobe/Reader8/bin:/opt/fltk/bin:/opt/dillo/bin:/usr/games/bin:/opt/vmware/server/console/bin:/var/spool/fax/bin:/opt/snav/bin:/home/rthompso/bin/eclipse:/home/rthompso/netbeans-6.0-200710020000/bin/:/usr/libexec/cssc
> PWD=/home/rthompso/src/repo.nitroproject.org/nitro/demo/blog
> rthompso at raker ~/src/repo.nitroproject.org/nitro/demo/blog $ env|grep RUBYOPT
> RUBYOPT=-rubygems
> rthompso at raker ~/src/repo.nitroproject.org/nitro/demo/blog $ 
>
> _______________________________________________
> Nitro-general mailing list
> Nitro-general at rubyforge.org
> http://rubyforge.org/mailman/listinfo/nitro-general
>
>   


-- 
Arne Brasseur
http://www.arnebrasseur.net
http://www.zhongwiki.com
http://www.bankske.org
arne at arnebrasseur.net



More information about the Nitro-general mailing list