[Nitro] Preparing nitro 0.50

Bill Kelly billk at cts.com
Fri Aug 10 15:25:06 EDT 2007

From: "Trans" <transfire at gmail.com>
> On Aug 9, 5:29 pm, "Bill Kelly" <bi... at cts.com> wrote:
>> From: "Rui Miguel" <rav... at fragmentized.net>
>> > Check thishttp://www.arnebrasseur.net/2007/07/01/the-daily-nitro/en/
>> > Hope it helps.
>> Thanks.  Looks like the "-r glycerin" does the magic.
>> Wow, my app doesn't run at all anymore.
>> Has "property" been completely eliminated in favor of
>> "attr_accessor" ?
> I'm surprised you didn't leave property as an alias of attr_accessor.
> I think that's a reasonable thing to do, since it's a simple thing,
> and will help backward compatibility (and remains available should you
> ever reconsider the attr_accessor decsision ;)

Just to add my 2 cents...  I would have preferred to continue to use
"property", because overriding attr_accessor feels a little too 
magic to me; and I tend to regard my og-managed classes as distinct
from "normal" ruby classes.  

To me, I don't think my og-managed classes become more readable by
making their definitions harder to distinguish from normal ruby
classes.  I feel og-managed classes are really quite special, and
require special treatment, so I kind of liked that property showed
that they aren't really quite ordinary.

But... just my opinion.  :)



More information about the Nitro-general mailing list