[Nitro] Component System instead of ClassMethods hack?

Jonas Pfenniger zimba.tm at gmail.com
Mon Jun 12 11:46:36 EDT 2006

On 12/06/06, TRANS <transfire at gmail.com> wrote:
> Is there a conflict with  the term 'Component' somewhere? Well, maybe
> it is too generic, but I don't like Aggregator, it's far too tied up
> with the concept of RSS these days. And I don't want to name it after
> something it incidently "does", but rather what it represents, eg. a
> synonym for 'Module'. Hmm... How about 'Capsule'?

Ok I agree,  it's better to name something to what it does.

What about 'Compound'. Nitro has Components for example (not in the
root namespace) and I suspect many other libs. Aggregat is nice also I



More information about the Nitro-general mailing list